Formula Excel

¿ Que es una formula Excel ?

Una formula excel es una instrucción que se ingresa en una celda, esta devuelve un resultado en la misma celda donde se ha puesto y puede depender de valores o texto de otras celdas.

No hay una cantidad fija de formulas de excel, todo depende del tipo de información y cálculos que se deseen realizar, podemos decir que se pueden generar millones de formulas, desde formulas muy simples como ( =A1+A2 ), en ese caso se están sumando los valores de  A1 Y A2, hasta formulas muy complejas para calcular impuestos de nominas o formulas de ingeniería.

Las formulas también se pueden generar a partir de una función ya predeterminada en excel, de echo es la forma mas usual de generar formulas, en este caso si se cuenta con una lista de categorías para estas funciones.

Categorías de funciones excel:

Funciones de complementos y automatización
Funciones de cubo
Funciones de base de datos
Funciones de fecha y hora
Funciones de ingeniería
Funciones financieras
Funciones de información
Funciones lógicas
Funciones de búsqueda y referencia
Funciones matemáticas y trigonométricas
Funciones estadísticas
Funciones de texto

Aunque excel ya trae una gran cantidad de funciones, también podemos programar nuestras propias funciones, a estas funciones excel las pone en la categoría de “Definidas por el usuario”, pero eso es mas avanzado y lo dejaremos para temas posteriores.

Ejemplos de formulas sencillas:

1.- Sumar cantidades en celda: en este caso se pretende sumar dos o mas cantidades en una misma celda, esto significa que no hay referencia a otras celdas.

=500+100

2.- Sumar los valores de celdas: Aquí si se hace referencia a otras celdas, por ejemplo: en la celda C1 queremos obtener la suma de los valores que se encuentran en las celdas A1 y B1

=A1+B1

3.- En A11 obtener la suma de los valores desde A1 hasta A10. ( En este caso usaremos una función )

=SUMA(A1:A10)

Si observamos en los primeros dos ejemplos no se usan funciones pero si se usan operadores aritméticos ( +    -    *    /     %    ^ ), en el caso tres, aunque se esta haciendo una suma, no se esta usando un operador aritmético sino una función, eso es porque resulta mas simple cuando la suma corresponde a un rango mayor ( A1:A10 ).

Ejemplos de formulas avanzadas.

Calcular la edad en Años, Meses y Días.
En A2 la fecha de nacimiento, en B2 la fecha actual.
=SIFECHA(A2,B2,”Y”)&” “&”Años,”&” “&SIFECHA(A2,B2,”YM”)&” “&”Meses,”&” “&SIFECHA(A2,B2,”MD”)&” “&”Dias”

Busca caracter o cadena dentro de otra cadena de texto.
En A2 ponemos la cadena de texto, en B2 el texto a buscar dentro de la cadena de A2.
=SI(ESERROR(ENCONTRAR(B2,A2,1)),”no encontrado”,”encontrado”).

Busca el siguiente viernes a partir de una fecha.
Ponemos la fecha en A1
=SI(DIASEM(A1,2)>5,A1+(7-DIASEM(A1,2))+5,SI(DIASEM(A1,2)=5,A1+7,A1+(5-DIASEM(A1,2))))

Comparar texto de dos celdas para saber si hay alguna palabra que coincide.
=SI(O(EXTRAE(A1,1,HALLAR(” “,A1,1)-1)=EXTRAE(B1,1,HALLAR(” “,B1,1)-1),EXTRAE(A1,1,HALLAR(” “,A1,1)-1)=EXTRAE(B1,HALLAR(” “,B1,1)+1,LARGO(B1)),EXTRAE(A1,HALLAR(” “,A1,1)+1,LARGO(A1))=EXTRAE(B1,1,HALLAR(” “,B1,1)-1),EXTRAE(A1,HALLAR(” “,A1,1)+1,LARGO(A1))=EXTRAE(B1,HALLAR(” “,B1,1)+1,LARGO(B1))),”verdadero”,” falso”)

Convertir un numero en horas con formula.
=(ENTERO(A2)/24)+(A2-ENTERO(A2))/24

Contar domingos entre dos fechas
=ENTERO((B1-DIASEM(B1,1)-A1+8)/7)
Contar lunes entre dos fechas
=ENTERO(($B$1-DIASEM($B$1-1)-$A$1+8)/7)
Contar martes entre dos fechas
=ENTERO(($B$1-DIASEM($B$1-2)-$A$1+8)/7)
Contar miércoles entre dos fechas
=ENTERO(($B$1-DIASEM($B$1-3)-$A$1+8)/7)
Contar jueves entre dos fechas
=ENTERO(($B$1-DIASEM($B$1-4)-$A$1+8)/7)
Contar viernes entre dos fechas
=ENTERO(($B$1-DIASEM($B$1-5)-$A$1+8)/7)
Contar sábados entre dos fechas
=ENTERO(($B$1-DIASEM($B$1-6)-$A$1+8)/7)

Contar el numero de veces que aparece un caracter dentro de una cadena.
=LARGO(A1)-LARGO(SUSTITUIR(A1,”a”,”"))

Contar vocales en cadena de texto.
Opción 1:
=LARGO(A1)-LARGO(SUSTITUIR(SUSTITUIR(SUSTITUIR(SUSTITUIR(SUSTITUIR(MINUSC(A1),”a”,”"),”e”,”"),”i”,”"),”o”,”"),”u”,”"))
Opción 2:
=SUMAPRODUCTO(LARGO(A2)-LARGO(SUSTITUIR(MINUSC(A2),{“a”;”e”;”i”;”o”;”u”},”")))
Opción 3:
=SUMA(LARGO(A3)-LARGO(SUSTITUIR(MINUSC(A3),{“a”;”e”;” i”;”o”;”u”},”")))

Comprobar si una factura esta vencida.
En A1 la fecha de la factura, en B1 la fecha de vencimiento, en C1 los días de crédito.
=SI(B1-A1>C1,”Vencida”,”Vigente”)

Encontrar el dato que mas se repite en una columna de registros.
=INDICE(A1:A10,MODA(COINCIDIR(A1:A10,A1:A10,0)))

Esta es solo una muestra de formulas avanzadas que se pueden hacer en excel, realmente hay una gran variedad y complejidad en lo que a formulas se refiere, esto dependerá directamente de lo que se requiera hacer, pero siempre es importante buscar la forma mas simple de encontrar la solución, no se trata precisamente de hacer la formula mas larga, por eso es muy importante estudiar las funciones de excel de acuerdo a sus categorías.

Esto es solo el inicio de esta pagina sobre formulas de excel, estaremos publicando muchos ejemplos mas y archivos para descargar.

Dejen sus comentarios, pronto estaremos de vuelta.